Komodo on Ubuntu

私の開発環境である

ActiveState - Komodo IDE Perl Python Tcl PHP XSLT - Dynamic Tools for Dynamic Languages
http://www.activestate.com/Products/Komodo/

Ubuntuで動かしたかったのですが、
見事にはまって起動しなかったのでメモ

まずはこのポルトガル語のサイトを参照して
インストールしてみました。

Planeta Ubuntu Brasil
http://planeta.ubuntubrasil.org/post/353

が、起動するとセグメンテーション違反とキレられます。

うーむなんでやろとおもったら、
なにやら

run-mozilla.sh

がだめっぽい。

KomodoXULで出来ているのでその辺かなと思いぐぐる。

放茫 Blogger - web2.0 ユビキタス遊学: [メモ] Firefox1.5インストール
http://sudo.com/blog/2005/12/_firefox15.html

[howto] General 5.10 - Firefox 1.5 installer script - Page 17 - Ubuntu Forums
http://www.ubuntuforums.org/showthread.php?p=572813#post572813

に解決策発見。

SCIMgccのバージョンあわせないとダメらしい

なんですと!!
(わかるわけないじゃないですか・・・)

GTK_IM_MODULE=xim ./komodo

で無事起動するようになりましたとさ。